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Using Lidar in ArcGIS 10 
Several tools are now available for working with lidar data in ArcGIS 10. Historically, because of 
the large file sizes, working with lidar datasets has been a challenge for those without 
specialized software packages designed for lidar processing. The release of ArcGIS 10 has 
provided many improvements in this field and can increase lidar processing and productivity 
for coastal applications. Listed below are a few of the tools in ArcGIS 10 that can be helpful for 
coastal applications and general lidar processing functionality. 
 
Checking Data Quality 
Data quality can vary with lidar depending on collection specifications, and there is always a 
chance of encountering anomalies in the data. Some common examples of anomalies include 
irregular minimum bounding shapes, “holes” in the sampling, and extreme high/low values 
(i.e., outliers). If any of these anomalies might affect project scoping or requirements, a user 
may want to check the data before performing any analyses. The Point File Information tool 
(requires 3D Analyst license) can assist in performing data quality assurance checks on lidar 
datasets. This step is optional and not required for the importing process of lidar data into 
ArcMap. 
 
The Point File Information tool, found in the 3D 
Analyst Tools (ArcToolbox > 3D Analyst Tools > 
Conversion > From File > Point File Information), 
reports important statistics about the raw lidar 
files. 
 
 

The result from this tool is a feature class 
that shows the 

• Minimum bounding rectangle for each file 
• Number of points recorded 
• Average point spacing 
• Minimum/Maximum z-values 

http://www.csc.noaa.gov/


                   Working with Lidar in ArcGIS 10   

Page 2 of 10 
 

 
When the feature class is loaded into ArcMap, the minimum bounding rectangle of each lidar 
file is drawn. Lidar data files are usually uniform in size, so if any of the feature shapes appear 
large or irregular compared to the majority of features from the feature class, they will appear 
different in ArcMap, which may require the user to refer to the corresponding lidar data file 
for further investigation. 
 
For more detailed information on the Point Information Tool output results and determining 
lidar data quality, refer to the Esri white paper: www.esri.com/library/whitepapers/pdfs/lidar- 
analysis-forestry-10.pdf. 
 
 
Loading LAS Files to ArcGIS ‒ LAS to Multipoint Tool 
This tool imports one or more files in LAS format, the industry standard for lidar data, into 
a new multipoint feature class. The tool enables the user to read the lidar data files and 
load them into the geodatabase. Loading the lidar files in a geodatabase allows a seamless 
mosaic of the entire lidar dataset, which then can be analyzed by ArcGIS tools. Supported 
LAS file format versions are 1.0, 1.1, and 1.2. 
 
LAS points can be classified into a number of categories, including bare earth or ground, 
water, and vegetation (low, medium, or high). The different classes are defined using numeric 
integer codes. Unfortunately, the LAS 1.0 specification does not have a predefined 
classification scheme, nor do the files summarize what, if any, class codes are used by the 
points. The data provider must supply this information. 
 
If working with the LAS 1.1 or 1.2 specifications, refer to the predefined classification schemes 
defined by American Society for Photogrammetry and Remote Sensing (ASPRS) for the desired 
data category. The following table lists the LAS class codes based on LAS version 1.2 defined 
by ASPRS. 
 
To import predefined LAS points from the LAS file or files, specify them in the Input Class Codes 
parameter. 

http://www.esri.com/library/whitepapers/pdfs/lidar-analysis-forestry-10.pdf
http://www.esri.com/library/whitepapers/pdfs/lidar-analysis-forestry-10.pdf
http://www.esri.com/library/whitepapers/pdfs/lidar-analysis-forestry-10.pdf
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When the LAS data files are read by the LAS to Multipoint tool, it can accommodate these 
classifications and separate them into unique feature classes. 

 

 
The LAS to Multipoint tool needs certain specifications depending on the project. An example 
for ground returns is displayed below. 

 
 
 

1.   A folder is specified for the data 
source. Individual files can be 
specified, but when large amounts of 
lidar data are being read, it is a best 
practice to specify the folder. 

 
2.   The Output Feature Class is specified 

in a file geodatabase. Multipoint 
feature classes exist in geodatabases 

2 and shapefiles, but geodatabases are 
3 preferred because of the extended 
4 capabilities of the geodatabase and 

the size restrictions of a shapefile. 
 

3.   The ground spacing is specified. This is 
acquired from the Point File 
Information tool or from the supplied 
metadata. 

 
4.  The Input Class Code to be extracted is 

5 
specified. The specific code entered 
will vary depending on the 
classification being analyzed 
(example: enter 2 for ground 
returns only). 

 
5.   The Input Return Values are specified. 

(Example: if the goal is to produce a 
ground surface, then the Input Class 
Codes need to be specified as 2 and 
the Input Return Values as 
ANY_RETURNS.) 

 
6 6.   The coordinate system is specified. 

 
7 

7.   The LAS file extension is designated as 
 a .las file. 
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Loading ASCII (X,Y,Z) Files to ArcGIS – Option 1 (requires 3D Analyst) 
The ASCII 3D To Feature Class tool found in the 3D Analyst Tools (ArcToolbox > 3D Analyst Tools 
> Conversion > From File > ASCII 3D to Feature Class) imports 3D features from one or more 
ASCII files into a new output feature class. 

 

 
In some cases, lidar data may be provided as an ASCII text file containing X (latitude), Y 
(longitude), and Z (elevation) information. The ASCII 3D to Feature Class tool will read the XYZ 
information and generate a new output feature class. The Input File Format may be set to XYZ, 
XYZI, or GENERATE. For more information on the differences in input file formats, please refer 
to http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00q900000092000000. 

 

 
A preview of the tool and some of the notable required inputs is provided below. 

 
 
 

1.   One or more input files or folders with 
data in ASCII XYZ or XYZI (with lidar 

1 intensity) or 3-D GENERATE format. If a 
folder is specified, all the files inside the 
folder named with the same extension as 
the file suffix parameter will be used. If 
multiple files are involved, they need to be 
in the same format. 

2.   The format of the input file(s). The format 
2 can be set to XYZ or XYZI or GENERATE. 

3.  The Output Feature Class Type. When 
3 points are input, the only valid types are 

POINT or MULTIPOINT. Multipoints are 
recommended when many thousands or 

4 
millions of points are involved. 

5 
4.   Input Coordinate System. (Note that if the 

dataset does not have a defined 
projection, it may need to be defined after 
the tool has run to show up in the right 
place. If the coordinate system is already 
defined, it is best practice to add 
it here.) 

5.   The average distance between points of 
the input. This parameter is only used 
when the Output Feature Class Type is set 
to MULTIPOINT. 

 

Once the tool has run, the output feature class will be added to the map project. This may take 
some time to load depending on the number of features in the dataset.

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#//00q900000092000000
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Loading ASCII (X,Y,Z) Files to ArcGIS – Option 2 (does NOT require 3D Analyst) 
Text files containing X coordinates (longitude), Y coordinates (latitude), and Z (elevation) 
components can also be brought into ArcMap and converted into a shapefile or geodatabase 
feature class. There are several table formats that ArcMap can read to bring point data into 
ArcMap as an event theme. These include DBase III, DBase IV, PRN, TXT, and CSV. 

 
 

1.   To ensure that ArcMap can read the data in the file 
correctly, the user may need to format the header 
(text editor), or columns (Excel), containing the 
longitude (X), latitude (Y), and elevation (Z) values. 
For text-based files (PRN, TXT, CSV), an example of a 
header would read “longitude,latitude,elevation” or 
“easting,northing,elevation” with no spaces between 
or after the header. If using Excel, format the columns 
containing the longitude (X) and latitude (Y) values as 
NUMBER, with a minimum of 8 decimal places. 

2.   Add the data to the map using the Add Data button. 
The file will be added to the table of contents, which 
will switch to the List by Source view by default. 

3.   Right-click on the table in the table of contents and 
select Display XY Data. 

4.   Specify the fields for the X, Y, and Z coordinates. For 
the X Field select longitude (Easting), for the Y Field 
select latitude (Northing), and select the appropriate 
elevation variable for the Z Field. Click OK. 

5.   Depending on the number of points included in the 
table, this process could take some time. 

6.   The data will be added to the map as an “event” layer. 
This layer is temporary and must be exported to 
become permanent. Right-click on the event layer in 
the table of contents and select Data > Export Data. 
Choose to export all features using the same 
coordinate system as the layer’s source data. Select 
the output feature class location and the desired 
name of the dataset. Click OK. 

7.  Once exported, a dialog will ask if the user wants to 
add the layer to the current map. (Note: If the data 
does not draw in the correct location, make sure to 
check the projection information.) 
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Apply LYR File Symbology 
Apply LYR File Symbology applies the symbology stored within a layer file to data layers within 
the active data frame that are the same type. 

1.   First, create a .lyr file that references geographic data stored on disk. Set the layer 
properties for the selected layer to the desired symbology. 

2.   In ArcToolbox navigate to System Toolboxes > Data Management Tools > Layers 
and Table Views and open the Save to Layer File tool. 

3.   Choose the Input Layer as the symbolized layer. Select the Output Layer to house 
the .lyr file. Click OK. 

4.   To apply the .lyr file properties to another layer, right-click the layer in the table of 
contents and select Properties. Click the Symbology tab and then click the Import 
option at the top right. Navigate to the .lyr file to apply the symbology. Click OK. 

 
Create Grid Profiles 
Create profiles or transects across selected grid themes (requires 3D Analyst). 

1.   This function can be accessed as a tool located on the 3D Analyst toolbar that is 
added with the Customize option on the main menu. Select Toolbars and then 
select the 3D Analyst toolbar option. The toolbar will be added to the display and 
can be docked similar to any other toolbar. 

 
 
 
 
 
 

2.   To activate the functions of the toolbar, a raster input layer must be selected from 
the Layer drop-down menu. Otherwise, the toolbar functions will be grayed out as in 
the image above. 

 
 
 
 
 
 

3.   Click on the Interpolate Line function (highlighted in the image above with the red 
box). Next, click the starting point on the raster layer and then double-click to finish 
drawing the line. 

4.   Once a line is completed, the Create Profile Graph option will become active (see 
image below). Click the Create Profile Graph drop-down menu and select Profile 
Graph to show the grid profile. The graph can be exported in many different formats 
by right-clicking the graph and choosing Export. To define parameters, choose the 
location in which to save the information. 
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 Subtract Grids 
 Subtract one grid from another (requires Spatial Analyst). 

1.   This function can be performed using the Minus tool found in the Spatial Analyst 
Tools Math toolset in ArcToolbox. (Note: the Spatial Analyst extension must be 
turned on to access the tool. Select Customize > Extensions and then check the box 
for Spatial Analyst.) 

2.   Open the tool by double-clicking it. Add the first raster to the Input raster or 
constant value 1 option. Add the second raster, or the value to be subtracted from 
the first raster, to the Input raster or constant value 2 option. Name and save the 
new raster to the desired location. (Note: if the two input rasters have different 
horizontal resolutions, the output resolution will need to be defined using the 
Environments tab at the bottom of the tool.) Click OK to run the Minus tool. 
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Cut and Fill 
Calculate the volume change between two surfaces (requires 3D Analyst). 

1.   This function can be performed using the Cut Fill tool found in the 3D Analyst Tools 
Raster Surface toolset in ArcToolbox. (Note: the 3D Analyst extension must be 
turned on to access the tool. Select Customize > Extensions and then check the box 
for 3D Analyst.) 

2.   Double-click the Cut Fill tool to open the interface. Input the raster representing the 
surface before the cut or fill operation. Input the raster representing the surface 
after the cut or fill operation. Define the name and location of the output raster. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3.   Apply a Z factor if necessary to adjust the units of measure for the Z units when they 
are different from the X,Y units of the input surface. The Z values of the input surface 
are multiplied by the Z factor when calculating the final output surface. Click OK to 
run the Cut Fill tool. 

 
 
Clip Grids 
Clip a grid by a selected polygon theme or graphic. This can be useful for calculating 
differences for a small section of a grid. 

1.   This function can be performed in several different ways using tools from 
ArcToolbox. This instruction will use the Clip Raster tool in the Data Management 
Tools > Raster > Raster Processing toolset that does not require any additional 
licenses. (Note: the Extract by Mask tool found in the Spatial Analyst Tools > 
Extraction toolset is an alternative method but requires a Spatial Analyst license.) 

2.   Double-click the Clip tool to open the user interface. Select the input raster to be 
clipped. 

3.   Select the Output Extent which can be an existing raster or vector layer to be used as 
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the clip extent. The clip output includes any pixels that intersect the 
minimum bounding rectangle. Or, input the rectangle bounding coordinates 
defining the minimum bounding rectangle to be clipped. 

4.   Define the name and location of the output raster. Click OK to run the Clip tool. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Convert Graphic to Shape 
Convert a selected graphic (e.g., one used to clip a grid) to a polyline or polygon theme. 
This can be useful for extracting, or clipping, study areas from large lidar datasets or 
DEMs. 

1.   This function can be performed using the Drawing tools from the Draw 
toolbar in ArcMap and doesn’t require any additional licensing. The Draw 
toolbar is generally in the ArcMap layout by default and is located at the 
bottom left area of the display. If it is not displayed it can be turned on 
using the Customize > Toolbars option on the main menu. 

 
 
 
 

2.   Select the drawing tool to be used to create the graphic for the area of 
interest from the drop-down menu (red box on image above). Click once to 
begin drawing the graphic. Click multiple vertices if needed by clicking 
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once for each section. Double-click to finish drawing the graphic. The 
graphic will remain selected in the map. 

 
3.   From the Drawing drop-down menu in the Draw toolbar, select Convert                       

Graphics to Features. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4.   Select to convert the graphic just created. Choose to apply the 
coordinate system from the data frame or another layer source. 

5.   Define the name and location of the output feature. 
6.   Select to delete the graphics after conversion option if applicable. Click OK. 

 
 
 
 
For Additional Help 
Please refer to the ESRI ArcGIS Help Library: 
http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html 
 

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html

